Indicators stopped working

Moderators: RFdemon, Site Team

Post Reply
atomichopppa66
Registered User
Posts: 2
Joined: Sun Sep 22, 2019 8:04 pm
Antispam - What is 3 x 12?: 36

Indicators stopped working

Post by atomichopppa66 » Fri Oct 11, 2019 7:39 pm

Evening guys. Hello!!! New member, new bike, a 2005 model. Just been for a spin, (first time), and the indicators were working, but have now stopped. Its raining and I'm guessing that might be the problem, but wondered if there's any obvious places to look etc. Thanks and regards.

User avatar
BASS 666
Paid up...
Paid up...
Posts: 233
Joined: Fri Dec 07, 2018 11:36 pm
Antispam - What is 3 x 12?: 36
Location: BELFAST

Re: Indicators stopped working

Post by BASS 666 » Fri Oct 11, 2019 8:59 pm

dodgy switch or flasher unit ????

User avatar
Lampy
Chairman
Chairman
Posts: 8206
Joined: Fri Nov 22, 2002 10:54 pm
Antispam - What is 3 x 12?: 36
Location: Meltham west yorks

Re: Indicators stopped working

Post by Lampy » Fri Oct 11, 2019 10:30 pm

Try pressing the hazard warning light switch on and off a few times and spray some wd40 or similar into the indicator switch.
SO MANY LAMPOSTS...........so little time . . . . STUPID PLACE TO PUT A WALL WASNT IT !!!!!
OH DEER !!!!

chairman@yamahaxjrownersclub.com

atomichopppa66
Registered User
Posts: 2
Joined: Sun Sep 22, 2019 8:04 pm
Antispam - What is 3 x 12?: 36

Re: Indicators stopped working

Post by atomichopppa66 » Sat Oct 12, 2019 6:45 pm

Hmmm, the plot thickens. The hazards don't work either (never tried them b4, so may have never worked), also found the tail lights don't work either. Brake lights work ok and the bulbs are also ok. Weird.... WD40 into the switches and we'll have another look tmrw. Thanks for the replies. :)

User avatar
hairy
Paid up...
Paid up...
Posts: 8324
Joined: Mon Sep 29, 2003 7:25 pm
Antispam - What is 3 x 12?: 48
Location: Luton
Contact:

Re: Indicators stopped working

Post by hairy » Sat Oct 12, 2019 9:01 pm

Also have a look in headlamp as connectors may be correded...always give a good dose of wd or simila in there and as mentioned switch gear
New and used XJR parts :arrow: http://xjrparts.co.uk
INDEPENDENCE DAY...31 January 2020 :D

freddy
Paid up...
Paid up...
Posts: 3819
Joined: Sat Sep 17, 2005 9:58 pm
Antispam - What is 3 x 12?: 48
Location: Leicestershire

Re: Indicators stopped working

Post by freddy » Sun Oct 13, 2019 11:11 am

Not 100% sure but there could be an inline fuse under the side panel on your model, worth a look.

User avatar
jooles
Events Coordinator
Events Coordinator
Posts: 2195
Joined: Tue Mar 06, 2012 8:41 pm
Antispam - What is 3 x 12?: 36
Location: Southampton

Re: Indicators stopped working

Post by jooles » Sun Oct 13, 2019 8:32 pm

you said the rear light doesnt work ,put it on side lights if you have no front side light ,it could be your ignition switch ,had the same problem a little while ago, the position lamps work through the ignition switch on the later models,i took my ignition switch to peices cleaned up the copper track inside ,and its been fine ,,,

Post Reply